DOWNLOAD CENTER
Video

Video surveillance products.

We strongly recommend using Internet Explorer version 10 or higher for the Download Center. Please add:

trust sites

to your list of trusted sites in Internet options, and set your security level to Low for trusted sites. Without these settings, files downloaded from the Download Center may be filtered by your anti-virus software, which can affect the reliable operation of our products after the upgrade.

Please be especially careful if you are using AVAST or McAfee Anti-Virus:

  • McAfee must be patched so that the number of installed patches is 4 or higher in the about screen
  • AVAST must be set to moderate instead of agressive mode